Access Denied while accessing deal attachments

deals
engagements

#1

While downloading attachments for a deal using (http://api.hubapi.com/engagements/v1/engagements/associated/deal/{$dealId}/paged), the url returned for some deal attachments work fine, but for some i get an access denied error

403 Forbidden

Code: AccessDenied
Message: Access Denied
RequestId: 747A3FEA15893817
HostId: 2ENWI0vrZPdIxg83qL5dVULrEc2fRMotQD/IjkX6Itt0u2ayzXjfGFu+lSYmi3lKi6eeYoZ1Eh0=

Has anyone faced the same issue?


#2

Hello,

I just faced this issue some minutes ago.
I don't know if you have found a solution but I post this for people who may found this topic and found a solution too.

With a collegue, with discover than the two buttons available in deal window to upload a file have not the same behaviour.

The first button called "Charger" in french UI (maybe should be named "upload" or "load" in english) upload the file but this one is only available when logged. It opens your OS file manager window to select the file you want.

The second one, called "Choisir un fichier existant" (maybe named "Choose an existing file" in english) upload the file too but this one could be download offline (tested in another browser). This button open an Hubspot window for choose the file you want to upload.

Soo, I don't know if in the english UI you have the two buttons as us but if you have them, maybe my answer could give you a possible solution to your problem.

Have a good day.

PS : as said in my post, I'm french. So excuse me for spellig errors, I not very good in english :wink:


#3

Hey all,

Uploading a file as an attachment to a deal (or other object) technically uploads that file to the File Manager. In order to maintain a separation between public File Manager files, attachments have a hidden flag set to true. This hides the file from the File Manager, and also prevents public access to the file. This is the expected behavior of these attached files, and it's not currently possible to change this behavior.