All customer OAuth tokens are invalid this morning


#1

Is anyone else having this issue? We’ve had our Hubspot integration for 2+ years, and upgraded to OAuth 2 about six months ago. We have ~15 customers who have data sync enabled between our product and Hubspot.

This morning I woke up to a few production alerts and upon investigation, every request to Hubspot’s APi is failing with this message:

"response" : {
	"status" : "error",
	"message" : "This oauth-token (redacted) is not valid for this request!",
	"correlationId" : "91042ad0-20bb-4af4-82df-ef89aebe9aac",
	"requestId" : "0f4c0f4c93374176605bacc1f0eafa04"
}

We’ve never seen this happen before - and we definitely refresh access tokens whenever they are expired. A failure across every account seems unlikely given that all customers enabled the integration at different times. Some have been around for years, some are as new as the last few weeks.


#2

Same here, updated our Hubspot integration to use OAuth 2 a few months ago, today ~20 customers seeing the same error message. Confirmed with 3 customers so far that they are using the Pro versions instead of Free versions of Hubspot Marketing or Sales. No solutions yet, but @chundley you are not alone!


#3

Hi @chundley and @linda

Sorry for the lack of response here. Our Auth team has been investigating this issue, and we believe we’ve narrowed down the problem but we’re still working on the fix. We’ll post an update here once this is fully resolved.

@linda are there any details that you’d be able to share for what you’re seeing? Are there specific endpoints you’re seeing this with?


#4

Thanks for the update @dadams! For our clients experiencing this issue, any data we try to pull in through the API for them gives the error above. Only 10% of our clients are experiencing this issue, the rest are connecting without errors.
We have seen this error pulling in data for these two endpoints:

  • Get all deals GET /deals/v1/deal/paged
  • Get all contacts GET /contacts/v1/lists/all/contacts/all

#5

Hey @dadams, looks like that error is gone today for all of our users. Thanks for the fix!


#6

Hi @dadams, This error occurs again frequently for some our customers. Please look into this. We are sure that, we are refreshing the access tokens whenever they are expired.


#7

Hi @Karthick_Shiva,

Are you seeing the exact error message listed above? Can you private message me an access token that you're seeing these issues with?


#8

Hi @Derek_Gervais

I'm also seeing the same error with some of our customers. Is there any way I could help you debugging it?


#9

Hi all,

I wanted to make sure the resolution of this topic was clear for newer posters; the original topic was in reference to an issue with HubSpot scopes that invalidated a number of access tokens. This issue has since been resolved, and is no longer affecting any access tokens. I'm happy to troubleshoot further authentication token issues, but I wanted to make sure everyone was on the same page (i.e. new issues will be separate from the original topic issue).

@Blendo can you direct message me an example of a refresh token you're seeing this error with?