An error occurred while attempting to create pipeline


#1

Hi to all,
while i try to create a pipeline I receive the error “An error occurred while attempting to create pipeline”.

There are no information about the “error”, so I suppose sometime ago I’ve created a pipeline with same name and after I delete it.

Someone can help me?

Thanks


#2

Some hubspotter can help me?


#3

@Grogdunn can you post the full error please? When did you create the original pipeline with the same name? We don’t hard delete things right away in case customers accidentally delete something and need it restored.


#4

@pmanca through GUI the full error was “An error occurred while attempting to create pipeline” (and nothing more).

through API, I created a pipeline “test” this request (endpoint POST https://api.hubapi.com/deals/v1/pipelines):

{
    "label": "test",
    "stages": [
        {
            "probability": 0.1,
            "displayOrder": 0,
            "label": "Identify",
            "stageId": "event-Identify"
        },
        {
            "probability": 0.2,
            "displayOrder": 1,
            "label": "Solution Proposal",
            "stageId": "event-Solution Proposal"
        },
        {
            "probability": 0.5,
            "displayOrder": 2,
            "label": "Negotiation",
            "stageId": "event-Negotiation"
        },
        {
            "probability": 0.9,
            "displayOrder": 3,
            "label": "Commitment",
            "stageId": "event-Commitment"
        },
        {
            "probability": 1.0,
            "displayOrder": 4,
            "label": "Won",
            "stageId": "event-Won"
        },
        {
            "probability": 0.0,
            "displayOrder": 5,
            "label": "Lost",
            "stageId": "event-Lost"
        }
    ]
}

Delete it and post again and receive the error:

{
  "status": "error",
  "message": "stageId (event-Identify) is a duplicate of a stageId in another pipeline",
  "correlationId": "c5329eed-b6bc-43e0-aef6-9b99e3ccd898",
  "requestId": "bab6fdc37b4d3f866584c2dff87b9d63"
}

Post again without stageIds give me the error:

{
  "status": "error",
  "message": "Error: all stages must reference pipelineId (da4cef92-0b79-4fdf-8607-dd85c3c1b1c3) which must exist in the deals_pipelines table",
  "correlationId": "8ae0b5d4-4b00-4ac3-bdea-2799416c5650",
  "requestId": "5bf95d2d125e0b3bf8d3a10df22c2372"
}

With some additional tests if the first request doesn’t contain “stageIds” the problem do not show up. But in the history of my account, I think, some developer (me? I don’t remember :slight_smile: ) had created the pipeline with stageIds.

Well someone can hard delete (or restore) the deleted pipelines in my account? Or I can do that myself?

Thanks


#5

@Grogdunn You can’t hard delete it from your end, and neither can I unfortunately.

Our support team can revise pipelines/objects so I would see if they can hard delete something as well.


#6

@pmanca Seems the Help portral doesn’t work well :frowning:

The server says to me 400 when I post the ticket. With this error (thanks Chrome Developer Tools :slight_smile: )

{
    "status": "error",
    "message": "Hub doesn't have scope zorse-webticket",
    "correlationId": "c6e2c794-7727-4404-a23f-167b29e6d02b",
    "requestId": "20f07758b4fbce6a23390524c0cbffc9"
}

#7

@Grogdunn What were you trying to post? A ticket from our support team? You wouldn’t have access to a zorse scope as that is an internal tool we use.


#8

@pmanca when i click on the link “Help & Support” , I do the login and a form will appear to open a ticket to support team. But I receive the error on the previous post.


#9

@Grogdunn I’m sorry, maybe there is something going on with our internal support tool. You might need to call in, please let them know there is an issue. They can file a bug report for our internal dev team to fix it. Software can be a fickle thing!


#10

It is likely due to the naming conventions on your Pipelines. I saw in an earlier thread that whitespaces are causing the same error. I was able to reproduce and fix this error by simple not including whitespaces in my pipeline title. As a sidenote, I was originally using the title “Jobs Pipeline” and fixed it by using “Jobs” as the title. I didn’t test to see if the keyword “Pipeline” was reserved.