Authorization failed: This hapikey does not have proper permissions! (requires any of [contacts-lists-access, contacts-lists-read])

contacts
developertools

#1

Whenever I try to use the API I get this message. Our customers can't subscribe anymore. This is not using the developer or test account, but our main account. How can I correct this?


#2

Hi @connor,

If you give me your Hub ID I can confirm, but that error almost always occurs when trying to access the Contact Lists API from a Marketing/CRM Free portal. The Contact Lists API is a feature limited to Marketing Professional/Enterprise portals.


#3

Does HubSpot offer anything like free developer account, which can be used to integrate and test any HubSpot API without purchasing a premium membership?

We have a basic free account and we want to use it as developer account but its lacking some permissions, particularly for contact list API. Its throwing 403 This oauth-token (XXXXXXXXXXX) does not have proper permissions! (requires any of [contacts-lists-access, contacts-lists-read] error.

Any help on this is greatly appreciated.


#5

Hi @Falguni_Moridhara,

Yes! You can create a developer account by clicking the CTA on this page.

Within your developer account (which is different than your production account), you can create test portals, which act as Marketing Hub Enterprise trials. You can then test all APIs in the test portal.

See this article for more information on creating a test portal.


#6

Thanks @Isaac_Takushi

We created a test portal and now its working perfectly!


#7

Hey @Isaac_Takushi

What account holder needs to do if they are receiving 403 Forbidden permission error message? Does this just mean, account does not have any contact list? or after adding list they also need to set some permission?

This oauth-token (XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXxxxxx) does not have proper permissions! (requires any of [contacts-lists-access, contacts-lists-read])


#8

Hi @Falguni_Moridhara,

Yes, the account getting that error must have contact lists (Marketing Hub Starter, Basic, Professional, Enterprise).

Additionally, the user connecting your app must have full permissions to all lists. For example:


#9

Thanks @Isaac_Takushi

I am using test portals and free version of HubSpot. I dont see such settings given with lists. There is no option of changing list permission. Is that specific to premium version? Or it should be available to every account?

Can you please share some user guide which can help us to change list permission?


#10

Hey, @Falguni_Moridhara.

Free accounts do not have access to lists, so if you are trying to connect an app to the free account, then you will receive this error.

What is the Hub ID of the account which you are trying to connect to?


#11

@Isaac_Takushi If I'm not wrong, its 5072488. I have copied this from browser address bar.


#12

Thank you, @Falguni_Moridhara.

Test acount 5072488 has a Marketing Hub Enterprise trial, so it does have access to lists. Is Bhargav the user who is trying to install an integration here?

What is the full authorization URL of the app Bhargav is trying to connect?


#13

@Isaac_Takushi I am sorry, I have created confusion by providing wrong account ID. 5072488 is definitely able to use lists and there is no problem in that.

Permission issue is faced for account ID 5033654 and I guess its obvious because its a test portal.

But I am curious to know, if 5072488 is fully capable to access its lists using any App, is there any way we have on our HubSpot dashboard by using which we can check list permission or change it? I mean I am not able to see "Permission" settings for lists in given account.


#14

Hi, @Falguni_Moridhara.

Thank you for clarifying the account showing the 403 error.

Account 5033654 is a free account (different than a test account). Free accounts do not have access to the lists tool, so that is why you are seeing the error. If you wish to use lists in account 5033654, you would need to upgrade to at least Marketing Hub Starter. Let me know if you would like more information there!

No list permission settings exist here because Bhargav is already a "super admin" and has all the available permissions in the account. (Other non-super admin users will have the toggles I showed above, but not free accounts.)


#15

Thanks a lot @Isaac_Takushi. Now this is clear to me.