BAD_REDIRECT_URI Authorization

oauth
contacts
deals

#1

When posting from postman to authorize I’m getting the following error
indent preformatted text by 4 spaces
{
“status”: “BAD_REDIRECT_URI”,
“message”: “missing or unknown redirect URI”,
“correlationId”: “72e8f7ec-fd6f-4ab5-9730-02592f81a355”,
“requestId”: “77516a270025c2b45b08f37fb3a0d583”
}

I’ve tried to start the re-authorization process from start to make sure I’m entering the same address (https://www.hubspot.com) however, this still results in the same error


#2

This is driving me nuts! :scream:

Steps I’ve taken so far:

  1. Created a brand new developer account and added an app to it
  2. Generated the first auth url where x = the client_id of my new app https://app.hubspot.com/oauth/authorize?client_id=xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx&scope=contacts&redirect_uri=https://www.hubspot.com
  3. Authorized fine and was provided a new code. Opened up postman and completed as follows

In the Header I have:
content_type: application/x-www-form-urlencoded
charset: utf-8

But when I POST I get the BAD_REDIRECT_URI. :frowning: and now I’m stumped with what to try next.


#3

Hubspot Developers on this forum be like:

I be like:


#4

Hi Marc, do you managed to solve the problem? We are having the same problem here
Thanks,

Giovanna