Batch update not working

contacts

#1

I'm running into an issue with the batch update API (https://developers.hubspot.com/docs/methods/contacts/batch_create_or_update). It says the batch size cannot exceed 1000 contacts per request so I have tried with 500, 100 and 10. All the requests succeed with a 202 response code but the contact are not updated. For the request to update 10 contacts, only the first 2 contacts are updated. Is there an issue with the API at the moment?


#2

I have checked the contacts that were updated with the batch update from yesterday (18h later) and the info is still not updated.


#4

Hi Aiwu,

Thanks for your patience. Can you show me the request you're making (please omit your HAPI key) so I can take a look? I was able to successfully run a POST using https://developers.hubspot.com/docs/methods/contacts/batch_create_or_update so there doesn't appear to be any current issues

Thanks!


#5

Hi Leif,
The request itself works, returns me a 202 but the contacts are not updated as expected. When I try with a single contact in the json request body, it updates the contact, but when I try with 10 contacts, only the first 2 gets updated and when I attempt with 100+, none gets updated.


#6

Hi Aiwu,

Would you mind providing me with a link to one of the contact records that you were able to successfully update using the API as well as a link to a contact record that failed?


#7

Hi,
I have sent you a private message.