Blank screens, Hubspot useless


#1

Hi,

Been trying Hubspot since yesterday, because I am looking for a proper customer database and tasks/project management app,

However I haven't been able to do anything since! My main problem right now: when I click on some menus like Companies or Tasks, all I get is a completely blank screen, and the hubspot tab title in Chrome is "Loading..."

Please can you help me quickly before I give up for another CRM app?

Regards,


#2

Hi @Hem,

This might be better suited for the general HubSpot Community, since it sounds like it might be an issue with the core HubSpot software. You can make an account here: https://community.hubspot.com/

That said, I'm happy to help see if we can identify the issue. Can you send me your Hub ID (see below)?


#3

Hello Derek,

And thanks for the support.
It's 4354601.

Looking forward to read you.


#4

Hi @Hem,

I'm able to navigate throughout that portal without experiencing any issues. Are there particular tools/pages/etc. that you're having issues with?


#5

Hey there Derek,

Yes, I am having the simple issue I can not use Hubspot at all :slight_smile: as I said, menus like Companies or Tasks will just not display at all!

I have been looking to replace Pipedrive with Hubspot as I just want a free app to centralize my everyday Task Management/Companies&Customers Databanking/Activies Tracking. But I have not been able to use Hubspot at all for almost a week, now.

Let me show you a screenshot who will not tell you much but just illustrate what I am saying.

On the left: the dashboard displays correctly. On the right: the Companies or Tasks menus just get blank!! I tried emptying my cache once, it worked for a few minutes, I created a company just to see but after a few minutes the problem came back...

Please, I really want to give its chance to Hubspot but this is going very well!
@Derek_Gervais


#6

Hi @Hem,

Where are you in the world? Very occasionally I've run into DNS problems in certain countries with some of the HubSpot back-end. China and Vietnam have both had sporadic issues (purely from my personal experience, I live in both places). It's totally outside of HubSpot's control.

In Chrome, here's a good thing to test:

  1. Open the Chrome Developer Tools (Ctrl + Shift + I or cmd + Shift + I on a Mac).
  2. Click on the Network tab.
  3. Refresh the page.
  4. Wait (a minute or two)
  5. See if there are any resources that are red indicating they couldn't load, or any notes in the console. It could be a timeout to a component causing a problem.

Other things to try: a different browser, a different network connection, using a VPN if you have access to one.

Good luck!

Cheers,
Mike


#7

@Mike_Ward

Hey Mike, thank you so much for chiming in. I'm pulling my hair out at the moment because Pipedrive is not giving me satisfaction at all in what I want to do and I need quickly to find another CRM/app for that, and I so wish to solve this problem quick and determine if HubSpot is the one or not!!

And... another thank you to you Mike as it seems you had a bullseye on that one:

So now that we (you!) determined where the problem might lie, what can I do?

PS: oops! I forgot to say I'm in Japan. If it is DNS related, no way I can play with a VPN so... does that mean I'm screwed regarding HubSpot?!


#8

Hi Hem,

I doubt being in Japan is the problem, I'd imagine there are thousands of companies using HubSpot in Japan. And I don't think Japan practices net censorship (unlike some other countries!!).

If you click on the name of one of those red lines, it should open up a little window on the right showing some more details. There should be a reason there for why it's failing - maybe like a '403 Forbidden' or '404 Not Found' or something.

Do you have another browser you can try? Try in FireFox or Edge.

Obviously, something between where you are and HubSpot is, is failing - browser, OS settings, router, ISP, DNS server.

Cheers,
Mike


#9

@Mike_Ward

Hey Mike!
I'm using Chrome.
Here are some examples:

Request URL:https://static.hsappstatic.net/crm_ui/static-3.2545/sass/CRM.css
Referrer Policy:no-referrer-when-downgrade
Provisional headers are shown
Referer:https://app.hubspot.com/sales/4354601/companies
User-Agent:Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/64.0.3282.186 Safari/537.36


#10

Hi @Hem,

Can you try with another browser? Either Firefox or Edge and see if you get the same problem.

Cheers,
Mike


#11

@Hem if you navigate to one of those red URL's do you get an error page?
Going to https://static.hsappstatic.net/crm_ui/static-3.2545/sass/CRM.css should show you a valid CSS file.

If it doesn't load properly, can you try it in an incognito Chrome Window?

If that fails, can you do a DNS lookup? You should see something like:
$ host static.hsappstatic.net
static.hsappstatic.net has address 104.17.7.210
static.hsappstatic.net has address 104.17.6.210
static.hsappstatic.net has address 104.17.5.210
static.hsappstatic.net has address 104.17.9.210
static.hsappstatic.net has address 104.17.8.210


#12

@Mike_Ward

Hey Mike,
I tried FireFox and it works!! This is super annoying as all my work is Chrome & Google Suite based, I do not want to migrate... but at least we ve narrowed even more the problem, didnt we? Looks like its explorer based?

@Kenneth_Breeman

Hi Kenneth and thank you so much for chiming it too. I am glad you people help me, the other thread right here is getting no success, this is saddening if you want to attract more attention to a product!

I tried to go to this link you gave me and by "valid css file" I am not sure what you mean, but all I got what this huge data screen:

and I even get the same result in an incognito window, so... I guess this is what you expected?

Same goes for the DNS lookup, sorry! as I am everything but a knowledgeable guy in such domain I was not sure what to perform for this DNS lookup thing, so I looked a bit on the web and then tried a dos command:
hubspotbug4
and then tried this website:


but I am sure the dos command is what you wanted to know?

Looking forward to hear from any of you! I think I will start creating my customer DB via FireFox for a start, just to gain some time! at worse, if I give up HubSpot I guess I could migrate the csv to any other CRM...?

Cheers.


#13

Looking at the results from those tests it looks like DNS is working properly for you and your browser is able to load the content that was previously failing.
I'm not familiar with how MX Toolbox generates requests so I'm not sure why it's failing for you, but it is working properly for me.

Can you retry using Chrome to access https://app.hubspot.com/ ?


#14

@Kenneth_Breeman

What do you mean by retry using Chrome to access https://app.hubspot.com/ ? I always try! I have this page that I keep open along this converstion tab and I just keep on refreshing them everyday since last Friday!!
In other words, I can reach this https://app.hubspot.com/ page, I can go to my Dashboard, but then I can not open any other menu (contacts, deals, companies, etc).


#15

Still need some help, if anyone has any lead/idea... Using Firefox is just a temporary band-aid and in no way a good solution (neither is it for HubSpot team, marketing wise).


#16

Holy #$%&'...

Guys, I found out. Our computers here have AdBlock app installed on Chrome, and I tried disabling it: it worked.
I can't believe it was just a Chrome extension. I apologize for the time taken, but problem solved! You may want to stick it somewhere in the FAQ or Troubleshooting steps, as a "this extension may prevent HubSpot to work correctly"...

Oh, and before you ask: putting HubSpot as an exception won't do, you have to actually disable the whole extension completely... talk about practical. Now to make it accepted here!

Cheers!


#17

It loads for me with AdBlock on Chrome, curious if it was a specific version of AdBlock that broke things. Glad it's working for you now!


#18

@Kenneth_Breeman

Hey Kenneth,

Well I would be glad to know your pro advice on that! Because for now,

  • I set AdBlock such as "AdBlock is disabled on this page.",

  • I put exceptions such as

@@|https://www.hubspot.com/products/crm?$document
@@||app.hubspot.com/$document
@@||www.hubspot.com/$document
@@|https://app.hubspot.com/

  • I have version 3.26.1 although I know version 3.27 came out yesterday (yet it won't update, don't know why).

But nothing will do except disabing the extension, which is a pain for many websites... so if you have any idea!


#19

Ah! You're using AdBlock, not AdBlock Plus. Disabling on the page should be fine since I don't think we serve advertisements inside our app.


#20

@Kenneth_Breeman

Yet the problem stays!