blockedDomains attribute doesn't work



I'm trying to block some domains. The form display well but doesn't block anything... Could you please tell me what's wrong with this code?

portalId: "xxxxxx",
formId: "xxxxxxxxxxxx",
css: "",
blockedDomains: ["", ""],
translations: {
en: {
required: "Please fill the required field.",
missingSelect: "Please select an option.",
forbiddenEmailDomain: "Please enter your business address",
manuallyBlockedEmailDomain: "Please enter your business address",
submitText: "WATCH NOW"


Blocked domains in form embed

Hi @fred_a, looking at David's response on this thread, does removing the space between blocked domains help fix the issue?


Thanks for your help @Connor_Barley! I tried ["",""] and "," (without spaces) but it still doesn't work..


Hi @fred_a,

I tested this a bunch in my own portal and it wasn't working at first. I then slowly deleted and re-added elements of your code. This code you sent over, and the code I used here in my portal seemed to work, but then it stopped working again. I'm going to have to keep digging into this one and update you when I have a solid answer.


ok, strange... Thanks @Connor_Barley!


Hi @fred_a, Engineering has pushed out a fix for this issue. Can you check to see if you're able to use that parameter now?


Thanks @Connor_Barley I replied in this topic: Blocked domains in form embed