Blog_Posts Versions responding with 404


#1

We checked for the revisions for a blog post, through dashboard-> Content->Blogs->Blog_posts->Edit->Revisions tab all the revisions are visible. But by using API “https://api.hubapi.com/content/api/v2/blog-posts/5312923614/versions?hapikey=*************” we are getting 404 error response. Shouldn’t we expect same result from both?
It would be really helpful if you can guide us to any resource to test out versions/revision API.


#2

Hi @devpartner,

That endpoint is returning a 404 for me too, though it should be correct. This appears to be an issue on our end; let me touch base with my team and get back to you with more info.


#3

Hi @devpartner,

That endpoint should now be functioning correctly; if you run into any other issues going forward, let me know!


#4

Hi Derek,
Now it works fine.
Blog Revision is also giving me problem. Please check on that


#5

Hi @devpartner,

You’re right, I was able to reproduce that as well. It appears the revision endpoints were temporarily down as a result of some changes on our end. I’ve already reached out to the team, and that endpoint is now functioning correctly. If you see any issues with this or other endpoints, don’t hesitate to reach back out!