Cannot Initiate Integration with Oauth 2.0

oauth

#1

I’m having some difficulties with initiating the integration for my custom application.

I made the following request: https://app.hubspot.com/oauth/authorize?client_id=xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx&redirect_uri=https://app.hubspot.com&scope=contacts%20timeline

Then I was taken to a screen that asked me to “Choose An Account.” Upon choosing the developer account, I received the following:

I verified that the client_id and other parameters are correct. Even if I selected the Marketing/CRM account in the previous step, it would simply just redirect me to the dashboards. I’m a little confused as to how to obtain the “code” necessary for creating an access token. I didn’t see a code appended to the redirect URL.

Admittedly, this is my first time using OAuth 2.0, so any help is appreciated. Thanks!


#2

Hi @cschouten1,

When authorizing an app, you must choose a portal with access to the relevant tools. If you’re requesting the contacts and timeline scopes, you must select a portal that has access to those tools. Your developer account doesn’t have access to any of the marketing/CRM scopes, and therefore wont be able to authorize an oauth connection.

Additionally, in order to authenticate an app in a portal, your user must be an admin. If the user trying to authenticate the app isn’t an admin, you’ll see the error above.


#3

@Derek_Gervais Thank you for your reply!

After re-investigating, it seems like I’m doing everything correctly in that I am listed as an admin in our Sales and Marketing portal; however, upon resubmitting the authorizing URL, I still get the same error.

Any other suggestions?


#4

Hi @cschouten1,

Can you direct message me the Hub ID of the marketing portal you’re selecting to authenticate the app, as well as the email address of your user in that portal?