Connection issue: handshake_failure


#1

Hi,
We have a process doing several calls (5 seconds sleep between each call).
The process began on 26 JAN 19:30 GMT and is scheduled to run every 15 minutes.
This Tuesday 07 FEB at 23:59 GMT we began receiving the following connectivity error for almost 10 hours.

GET /deals/v1/deal/recent/modified?count=500&since=1486508520000 HTTP/1.1
A Web Service request has detected a SOCKET error whilst invoking a web service located at
host api.hubapi.com, on port 443, on path /deals/v1/deal/recent/modified?count=500&since=1486508520000.
An error occurred whilst performing an SSL socket operation connect
javax.net.ssl.SSLHandshakeException: Received fatal alert: handshake_failure

Could it be that our system was blocked by your application firewall?
As you automatically block any unusual traffic … requests are for the same page coming from a single source.
The issue was solved by stop & start of our process, but we don’t see any connectivity problem on our side.

Thanks.
/Jean


#2

Hi @deJean216

This would not be caused by any block by our application firewall, since in those cases you would still be able to connect but would receive a 403 response.

Do you have any more details on the specific problem with the handshake?


#3

hi David,
No other details in our log.
Thx.


#4

Hi David,
I believe you have found a solution to this problem by now.
I am also getting same error. Please help me resolving it. I am trying to get a solution since a week but no luck.
Waiting for your response!!!