Content Scope Permission Problem

oauth

#1

We are running into issues with a specific user that cannot authorize an app. Here is a screenshot of the UI message:

Here is the 403 Response:
{status: "USER_UNAUTHORIZED", message: "user does not have permissions to authorize scopes",…}
correlationId: "7dc18e95-e060-4807-bc84-eff95b80b0ec"
message: "user does not have permissions to authorize scopes"
requestId: "1662a17627c11be7b2cc1f6dc1c3a4bd"
status: "USER_UNAUTHORIZED"

I have read through many forum posts and many are similar, but none of them have a solution. I've checked the user permissions and the user in question is an Admin with publish/read/write access to all content types. The integration needs access to Contacts, Forms and Content. I know the issue is with Content because when I take the content scope off the authentication works, but the integration doesn't function fully because it needs the content.

This was the closes Topic: Problem getting acces to content scope

@Derek_Gervais I can send you the HubId and user


#3

Welcome, @t.murphy!

The easiest way to resolve this is to have a Super Admin connect the app.

If that's not an option, though, would you share a link to the account's user management page below and identify the first three letters of the user's name (no need to give the full name)?


#4

@Isaac_Takushi It would beneficial to not use Super Admin.

https://app.hubspot.com/settings/597489/users
jim


#5

Thanks, @t.murphy.

That does seem strange to me. I would expect Jim to be able to connect your integration, given those permissions and the subscription level of the account.

Would you mind sharing:

  • Your app ID
  • The authorization URL you are using (with the scopes)

Appreciate it.


#6

Yes,

Here is the App ID: 59290
Auth URL: https://app.hubspot.com/oauth/authorize?client_id=da7a8748-4a03-4ce6-9316-69050b2f8f0e&redirect_uri=https://marketplace.lingotek.com/connect/auth/514/hubspot&scope=content%20forms%20contacts


#7

And this has worked in other portals and other accounts and with a different user in this same portal that has the exact same permissions. It is odd that it is not working for this user and we need it to work for this specific user.


#8

Hi @t.murphy,

I hope you had a good weekend!

I see Jim is now a Super Admin. Are you still encountering this issue?


#9

@Isaac_Takushi Now that Jim is a Super Admin, the authorization is working, but we need to figure out why the permissions were not working, because that user will need to go back to the previous permissions.


#10

Understood, @t.murphy.

To troubleshoot effectively, though, I'll need Jim moved back to the previous permission set. My team and I can't property investigate the issue if we can't reliably replicate it.

Let me know when Jim's role has been changed!


#11

@Isaac_Takushi That makes sense. Please use the user with the first three letters of "edw" There is only one. His user is having the same issue.


#12

Thanks, @t.murphy.

Looks like that user is not yet an admin (I believe Jim was). Could you toggle on admin permissions for that user and let me know if the same error occurs?

Thanks!


#14

@Isaac_Takushi, permissions are updated, but still experiencing the same issues.


#15

Happy Birthday, @t.murphy!

Understood, I'll be investigating this issue more closely with my team today. I appreciate your patience!


#16

Hey, @t.murphy!

One more thing. Could you have Jim or another super admin disconnect Lingotek (just app 59290) from this page while my team investigates?


#18

Hey, @t.murphy.

We'd like to confirm that the permission changes you made to "Edw" have fully processed. Could you have him disconnect the Lingotek app (per my last post) and then try to connect it again?


#19

Hey, @t.murphy!

Checking in. Could you confirm whether you've completed the steps above and are still encountering the issue?


#20

@Isaac_Takushi, yes we performed the actions (except for disconnecting the app since we are still doing some testing on our side too and need it connected), but the same behavior is still happening. And yes, we verified that the permissions were set on Edw

Thanks.


#21

Thanks, @t.murphy, but having a super admin disconnect the app and having Edw try and reconnect it is a key step. Please let me know when this is done.


#22

Oh, I understand. I will try that!


#23

@Isaac_Takushi I tried disconnecting the app using a super admin and then I used Edw to try and authenticate and it did not work, I got the same error.