Create deal failure


#1

Hi Guys,

Am having an issue creating deals. Here is every information for my API call and the response I get.

https://api.hubapi.com/deals/v1/deal?hapikey=mykey

Note: I have attached the sample request image as a reply to this post

Just to mention, I also tried the dealstage value as “in_verification” instead of 3ef54a7b-474b-4866-98e3-1030fd1af681 and none worked.

Help will be appreciated.

Thank you


#2

Here is a follow up image to my earlier post on Create deal failure. It shows the request that produces the error I shared in the original post


#3

@ATIntegrated In the UI did you make a deal stage with the right name on your default pipeline? The error seems to think that you are trying to make a deal in a deal stage that does not exist?


#4

@pmanca From my knowledge of Deals, dealname can be any name. I don’t know of any default name for a pipeline. The dealstage does exist and the dealname is the name of the customer, and that is different for every single deal created.
If what I stated above is not correct, i’d be glad to know more.

So to answer your question, Yes, the dealstage do exist and I confirmed that with Hubspot support


#5

@ATIntegrated To clarify does the deal stage exist within that pipeline?

default is the internal name to the pipeline that is called “pipeline” a tad confusing but that is what it is referring too.


#6

Yes, the deal stage exists.


#7

would you mind private messaging me the full error that has your portal ID and dealstage not blacked out?


#8

@pmanca How do I do that?


#9

@ATIntegrated You can click on my name and hit the envelope. If you are new to the forum you might not have permission just yet to do so. In the case pease just email it to me at pmanca@hubspot.com


#10

I sent you an email with the working copy. The resolution for this for anyone reading this in the future was an incorrect value for the pipeline as it was a custom pipeline.


#11

Yeah, the account owner had deleted the default pipeline and created a custom one, so requests were failing as a result. Works great now

Thanks again @pmanca