Delete readonly/hubspotDefined property that I created

contacts

#1

I was able to create a contact property (by accident) via the API that has the field hubspotDefined = true and now I am unable to delete it via the API or website.

Get the error:

{
    "status": "error",
    "message": "The Property 'customname' has a read-only definition, and can't be mutated.",
    "correlationId": "cd13cd30-e6a1-4bc6-a3b5-01f4f7b87810",
    "requestId": "55c50600f546c12847b7d0ec0b2eca2b"
}

I then tried to change hubspotDefined field to false but get the same message as above.

Next I tried to change the read_only_definition feild but get the error:

{
    "status": "error",
    "message": "Field 'read_only_definition' cannot be modified for property 'customname'.",
    "correlationId": "0ef7067a-1919-40ac-bd52-f39a980c66be",
    "requestId": "6ccf14e3f3dfc9b28f3feef1fdb32edd"
}

Tried asking my contact at HubSpot but after 6 weeks no help and told to ask in forum.

Frustrated!

Please can anyone help?


#2

Hi @Gareth_Lee,

Can you message me directly with your Hub ID and the internal name of the property that you’re looking to delete?