Dev Account set to post API Calls


#1

I am using Postman to try and make a call and using just ONE property for a test and the test post is not showing up on my Contacts list even tho I get a 200 OK response from server

post url: https://api.hubapi.com/contacts/v1/contact/createOrUpdate/email/gerry@test1009.com/?hapikey=xxxxxxxmyapikeyxxxxxx

json packet
{
“properties”: [
{
“property”: “email”,
“value”: "gerry@test1009.com"
}
]
}

response 200 OK
{
“vid”: 51,
“isNew”: true
}

then I go to Contacts on my dev account and nada

@ale@hubspot.com


#2

Hi @gasher,

Developer portals don’t have access to contacts, or any other of the normal tools, they just the developer tools (creating apps and test portals). Did you create a test portal for this? Test portals are separate from the developer account, so if you’re creating contacts in the test portal, you’d need to log into the test portal (which you can do from the Test Portals dashboard in the developer account) to see any contacts.


#3

Yes I did and the leads go thru just fine on my live account they just will not go thru to the dev portal … I am just working on my live account for now but thanks for the reply. I am able to post to hubspot from my dev machine without issue until I introduce the “hs_context” perperty along with its 6 properties

I receive a 400 error from the server as being a bad packet but goes thru just fine in postman SMH in anger


#4

Hi @gasher,

Developer portals can’t have contacts created (or access any of the regular marketing/CRM tools) but you should be able to create them in a live or test portal. If you’re running into issues with the hs_context parameter, can you double check that it’s properly encoded/formatted? Can you include the request you’re making here so that I can take a look?