Domo Integration Issues


#1

Hi, I’ve been using HubSpot with Domo with connected my data seamlessly. I recently received an OAuth 1.0 Deprecation error [ https://developers.hubspot.com/docs/faq/oauth-1-deprecation ] basically stating I needed to update my data connection. Checking with Domo, they said I should re-install the data connection within Domo and I’d be good to go.

Going through the data connection process in Domo you are instructed to input your “Hub ID” and are then redirected to HubSpot where it then works to authenticate your credentials. At this point I receive an error from HubSpot stating… “You do not have the correct role to grant these permissions. Please contact your administrator.”

My role is Super Admin. Hub ID is 3354975.

Hoping someone has an idea what the issue may be. Any help is greatly appreciated!


#2

Hi @noworries,

That error usually appears when an integration requests scopes that the portal does not have access to. This wasn’t usually a problem with OAuth 1 since scoping was handled differently. The portal you linked to is a marketing free portal, so perhaps Domo is requesting some marketing scope that your portal doesn’t have access to?

Domo should be able to provide you with the authorization URL and scopes their using, which will help in troubleshooting this error.


#3

Hi Derek!

The data connection has worked fine up until the other day (and I haven’t tried to change what type of data we’re pulling). So no, I don’t feel as though we’re trying to pull data from areas of hubspot we don’t have access to. All-in-all we’re just pulling CMR data which we use/input regularly. I did get a response from Domo saying;

“At this time, we have had reports of users who have recreated the connector and it is working for them. The next step you need to take is to reach out to HubSpot support and make sure that your account credentials are updated for OAuth2 security they are now using.”

Any chance there is a way to see/confirm our instance has been updated?


#4

Hi @noworries,

I am not seeing Domo in your portal’s integrations page, which means that it hasn’t been successfully installed. I did a bit of digging, and I can see that Domo is requiring the following scopes:

  • contacts
  • content
  • reports
  • forms
  • social

Since your portal is a marketing free portal, you don’t have access to the social scope, which is why the installation is failing. If Domo requires the social scope to work, then you won’t be able to install it in that portal. If it’s not required, they can request it under optional_scope instead, allowing portals without access to the social scope to install it. I would recommend reaching out to Domo support with this information for some clarity on what portal types they support and if they’re able to adjust how they’re requesting scopes.