Ending support for the previous version of our form embed code

forms

#1

Hi everyone,

In June of 2015, we released the current version of our forms embed code. Since then, the previous version of the embed code has continued to work, but has only received maintenance updates and does not support the same features of the newer code.

In order to make sure that all HubSpot customers are on the same feature set, we will be redirecting the old form embed code to use the current form embed functionality starting on January 31st. The old embed code will continue to load your forms, but they will load with the current feature set.

As part of this update, the validationOptions function will no longer be supported. Custom validation is not supported with the current form embed code, so if you require custom validation on your forms, you may need to use a custom form and use the Forms API to send the data to HubSpot.

If you are using any other features of the embed code, no change should be required, as the old embed code will continue to load your forms, just with the updated functionality.

You can find more details about the updates to the embed code in the original announcement here.
Please let us know if you have any questions about this update.