Error 403 : cannot access an unscoped endpoint


#1

Hi,

We have an integration with hubspot since few weeks in production but since few minutes, we are starting receiving following answers from Hubspot
{“status”:“error”,“message”:“This oauth-token (XXXX) does not have proper permissions! (cannot access an unscoped endpoint)”,“correlationId”:“e5112809-7e6a-4d58-82ac-7f7bbad8cf82”,“requestId”:“412e0385bff2ffe2e116a7362d7fa2e3”}

Currently it happens only on following url call : /contacts/v1/contact/vid/:vid/profile

Could you help?

It starte around 16:52 paris time


Can't create contact using OAuth autentification
Cannot access an unscoped endpoint Error
#2

I’m getting the same error, is Hubspot perhaps running upgrades ?


#3

I’m getting the same error too. Any official announcement on this?


#4

I am also seeing this as of 10:50 EST. Any details would be greatly appreciated.


#5

Hi everyone, we’re seeing this as well. Our Contacts and Auth teams are investigating, we should have an update soon.


#6

Hi everyone, sorry for the wait here. This should be resolved and the Contacts APIs should be working normally with OAuth2 tokens again. If anyone is still seeing that unscoped endpoint error please let us know.


#7

@dadams i can verify it’s working on my side