Failed connection from Auth0


#1

We are using HubSpot for our normal campaign emails, but we also need to utilize its SMTP server to enable Auth0, which we use to manage our login process, the ability to send password reset and password change type of emails. While I can create a test mail client and successfully send a mail through smtp.hubapi.com, the exact same credentials fail when I try to send a test email using Auth0. The only error codes I get are:

{
“email_type”: “try_provider_configuration_email”,
“to”: “”,
“error”: “Invalid login sequence while waiting for “334 VXNlcm5hbWU6”: 334 VXNlcm5hbWU6 R6n7Dck9nW4w1nb83nMhVR0 - hssmtp”
}

I also have Auth0 looking at this issue. However, I can also get a test email to work from Auth0 to a test SMTP server at smtp.gmail.com, so the issue isn’t completely on Auth0’s side. What could be causing the incompatibility here?


#2

Hello @gregcharles,

have you ever solved your problem? I’m trying to setup the Sendgrid integration and have found the very same log:

{
  "date": "2017-06-29T09:13:19.558Z",
  "type": "fn",
  "description": "To: zat@gmail.io",
  "connection_id": "",
  "details": {
    "email_type": "try_provider_configuration_email",
    "to": "zat@gmail.io",
    "error": "The provided authorization grant is invalid, expired, or revoked"
  },
  "log_id": "49570627966157796216771217468853979674542363655880572978"
}

#3

In our case we used incorrect API Key.


#4

Glad you worked it out! In our case, Hubspot actually fixed the issue on
their end, so anyone still seeing something similar must be seeing it for a
different reason.