Failed to connect to api.hubapi.com port 443: Connection refused


#1

I'm getting the following error when trying to connect to this endpoint: https://api.hubapi.com/contacts/v1/contact/createOrUpdate/email/

Failed to connect to api.hubapi.com port 443: Connection refused

Any idea what would cause that? I tested the same endpoint/JSON using Postman and it worked fine.

I'm using PHP/cURL to connect. It's worked fine in the past.


#3

Hey @Chadr, I'm not sure of any reason you'd see that error. Do you have any more details or logs you can share with me so I can dig in?


#4

We are having the same issue using PHP/cURL to connect. It quit working 4 days ago after almost 6 months of working without a problem:

CURL_GETINFO:
Array (
[url] => https://api.hubapi.com/oauth/v1/token
[content_type] =>
[http_code] => 0
[header_size] => 0
[request_size] => 0
[filetime] => -1
[ssl_verify_result] => 0
[redirect_count] => 0
[total_time] => 5.016954
[namelookup_time] => 0.004387
[connect_time] => 0
[pretransfer_time] => 0
[size_upload] => 0 [size_download] => 0
[speed_download] => 0
[speed_upload] => 0
[download_content_length] => -1
[upload_content_length] => -1
[starttransfer_time] => 0
[redirect_time] => 0
[redirect_url] =>
[primary_ip] =>
[certinfo] =>
Array ( )
[primary_port] => 0
[local_ip] =>
[local_port] => 0
)

CURL ERROR:
stdClass Object ( [error] => Failed to connect to api.hubapi.com port 443: Connection refused )

NOTE: This started the DAY that our SSL certificate was renewed. I assume it is related to this, but not sure why or how.


#5

I haven't dug in real deep, but my impression is ours may have stopped around the same time.

I turned on SSL for our HubSpot hosted sites around the same time - that's the only thing I could think of that changed relative to Hubspot. But they seem like completely different things, so may be unrelated.


#6

Update: This issue eventually resolved itself on our servers, possibly a caching or propagation issue, but am unsure. Nothing changed from the programming side. Hope this resolves itself for you as well Chadr.