Form submission returning 403 (SOLVED)


#1

Right now I’m trying to figure out why the form submission API for my dev site is giving me a 403. The docs state that there is no authorization required, do I’m unsure why I get nothing but a 403.

I was able to reproduce the error via Postman:
!(https://i.gyazo.com/7aead3d7e4d7fbe6a301a7515ec6ebe5.png)

The empty form exists, I created it myself.

The client wants this integration in place last week and this last step is the only thing I know of that is holding me back.


#2

@Ricky when you made your “empty” form in HubSpot did you include all of those fields in it? The form can’t be empty it must include a field for firstname/lastname/etc…


#3

No actually. I’d been informed by a tech that the form didn’t actually need
any fields defined. Thus it only has the default email field. I’ll fill in
the fields I need and report the results.


#4

And it didn’t make a difference. I made sure the form had all the fields as identified by their internal name.

However I did some deeper testing. It seems there was a failure to URL encode a string that contained “&”. I’d assumed that my libs would do that for me, but that’s what assuming get ya.

After making sure everything was URL encoded, it worked - even after I removed all the fields from the form that I’d added for testing.

In conclusion:

  1. MAKE SURE TO URLENCODE. Don’t trust your libraries to do such for you even when the library should “know” that it’s going to be needed.
  2. No, the actual form on the site does not need any fields added unless you wish to use the form directly. If you are just POSTing your own custom form, don’t sweat trying to duplicate the setup.

#5

Cool, i’m glad you have it working. I appreciate you coming back and posting the solution to help others down the road.