Forms API not accepting HAPI key

forms

#1

We have started receiving errors from the Hubpot API when trying to fetch a form using this endpoint:
https://api.hubapi.com/forms/v2/forms/

The error returned is: "This endpoint does not accept EXTERNAL hapikeys, and has no special allowances for this hapikey"

Even trying the demo link in the documentation gives the same error so it doesn't seem like it's a key issue

https://api.hubapi.com/forms/v2/forms/1eae3941-9ce8-411d-8b91-87a92c0c9d5c/?hapikey=demo

Any ideas?


#2

We are experiencing the exact same issue with our account. Any help would be greatly appreciated.


#3

We are also experiencing this issue.


#5

Thanks for reaching out, @daveb, @mwhelan, and @jeffnappi.

I've been able to reproduce this behavior with my own external API key.

The same key works for other endpoints like Get all forms and Get contact by ID. Can you confirm whether this is the case for you all?

Please share your Hub IDs as well so that I can record the impact of the issue.


#6

@Isaac_Takushi Yes, I can confirm that getting all forms still works for us. Our Hub ID is 106921.


#7

We are experiencing the same issue, but not getting the forms at all. Hubspot ID is 2266771.


#8

Hey, all.

The forms team just pushed a fix which should be in production. Can you confirm whether the issue has been resolved?


#9

Solved the issue for us! Great! Thanks!


#11

Everything is working as expected now. Thanks!