Gettinng error when update deal

deals

#1

When we tried to update on HubSpot, we have found below error. we have tried to contact Hubspot team as well but did not get response.

Will you please help us to short out this issue.

Request Data :

Url: https://api.hubapi.com/deals/v1/deal/362271191?hapikey=4531eae3-a3a3-4b65-aac2-f8dc43bbf43da

{
"properties": [
{
"name": "socialmediastatus",
"value": "approved"
}
]
}

Response :

{
"status": "error",
"message": "This hapikey (4531eae3-a3a3-4b65-aac2-f8dc43bbf43da) doesn't exist!",
"correlationId": "1e6f43f7-198a-413a-956a-7dae125c2af5",
"requestId": "7c9fe0198506684f3ade4e652d28884b"
}


#3

Hi @mohit_saxena, can you send over your HubID so I can take a look? From the message, it looks like that Hapikey is deactivated. Happy to take a closer look at this for you!

On another note, how did you get in touch with Support? They should have responded in under 24 hours if you had submitted a webticket. Support's SLA is < 24 hours for webtickets, and < 3 minutes when calling in if you have phone support in your plan!


#4

Also, for future reference, don't include your hapikey in posts here since this is a public forum! thanks :grinning:


#5

Hi,

When will we expect your response? we are still waiting for your response.


#6

Sure. I will take care. thanks.

Also, let me know when will i expect solution.

Thanks
Mohit


#7

Hi @mohit_saxena, I'm going to need your HubID to dig into this further. I've made the same request to my own portal with my own hapikey and was able to do so successfully. Please also make sure you're using the correct method (PUT), and that the hapikey you're using is still valid.

To find your hapikey, you can go to Settings > Integrations > Browse All Integrations > Your Integrations > API key. See screenshot below

The error you're receiving appears that your API key is deactivated.