Have HubL Server start in working directory



I’m trying to start the HubL server using a gruntfile in a folder under work/hubthemes.
The config.yaml says that templateBaseDir is supposed to default to the current working directory.
Unless I specify a full relative folder to a theme dir for templateBaseDir, the server blows up when starting.
I’ve tried to omit it, use ., ./ or whatever, but seems like it expects a full path.
I’d like to be able to keep a grunt file in each folder under work/hubthemes that starts the server for the specific project instead of having to edit config.yaml each time, or as said, replicate the entire structure.

I guess I could create individual batch files that point to individual config.yaml files, but hey - the comment is there saying it should use the working dir. :wink:

Tips appreciated. :slight_smile:

– edit –

I’m starting to get it to work using a parameter for a custom yaml file to the batch file. Guess I’ll manage. Thanks.
I think the bottom line actually was a missing custom-modules folder, since it isn’t there by default in a new portal.
Downloaded ./custom and tried to go with that.