Hidden Input Fields not showing up on into collected forms


#1

Is there a way in the hubspot/leadin integration we have for form submissions to capture hidden fields, and if not is there a way to hide the fields that they will still be collected by the code?

all the fields that are displayed are being collected properly but

is not being captured and captured and sent.

Any insight on this would be very helpful.


#2

@dsadnick are you using the lead flow for marketing free or are you in a different version of the marketing platform? Are you embedding the form or are you using the forms API to pass the data along?


#3

@pmanca I have this issue too – turned on automatic (“magic”) form collection through marketing, and want to pass a hidden field through a custom (non-hubspot) form on our website but not sure how to do this.


#4

Same issue there :slight_smile:

Does someone found a solution?

Thanks!


#5

@thbs @Sebastien_Chronogolf Did you try and add the hidden field to the hubspot side of things? HubSpot needs to know what to look for. What version of HubSpot do you have. I believe marketing free does not get access to custom fields beyond first name, last name and email.


#6

@Sebastien_Chronogolf @pmanca Solved it with a non-hidden input inside a div with this styling:

<div style="visibility:hidden;pointer-events:none;width:0;height:0;position:absolute;top:-9999px;left:-9999px;z-index:-1;" tabindex="-1">

#7

@thbs ver cool! thanks for coming back and updating the post with the working solution


#8

The form field must not hidden, nor inside any display:none parent. In addition, it must have a label or placeholder, otherwise the form will get parsed incorrectly. If the property is a checkbox/Boolean, a type=text should still be used with value of true.