Hubspot API works from one URL but gives 403 from another

contacts

#1

I am using php to send a get to the following URL:
https://api.hubapi.com/contacts/v1/contact/email/" + emailAddress + "/profile?hapikey=XXXXX
Of course the details are filled out correctly when the get actually happens. When I run it from a development server I have no issues with it and it returns the correct data, however when I run it from the a different server (with a different IP address but otherwise very similar environment) I get the following error:

{
    status: {
        http_code: 403
    },
    contents: "<HTML><HEAD> <TITLE>Access Denied</TITLE> </HEAD><BODY> <H1>Access Denied</H1> You don't have permission to access "
    http: //api.hubapi.com/contacts/v1/contact/email/harve@miramar-group.co.uk/profile?" on this server.<P> Reference #18.dad3dead.1501237865.9f7254 </BODY> </HTML> "
}

I have looked at the debugging for the curl requests from both files and they look pretty much identical up until the response which is obviously 200 and 403 respectively. Is there any reason why access might be being denied from this specific site?

Many thanks,

Harvey