HubSpot Integration App Problem: You do not have the correct role to grant these permissions. Please contact your administrator

oauth

#1

Hi,

I am running into a problem where my previously working integration app stopped working due to some reasons. Everytime I try to connect it with a new portal it gives following error:

The app scopes section is attached.

Is it just me or HubSpot have something going on? Thanks in advance.


#2

I’ve seen that happen before in my development environment. Eventually the issue went away (like within a couple hours). I believe at that time HubSpot claimed to be updating something with OAuth


#3

Here is the post from when I had that issue: Permissions Problem Post


#4

Hi @_umairk,

Are you still running into this issue?


#5

Yes still the same. It won’t work giving the same error for any new portal I tried to connect.

However with a portal I am previously connected with, it gives following error:


#6

did anybody find out what was the problem with this? i am getting that and cant find out what’s wrong…


#7

Hi @Alejandro_van_Houtte,

It’s likely due to one of the following reasons:

  1. The user attempting to authorize the integration isn’t an admin. Only admins can install integrations.
  2. You’re trying to install an integration that doesn’t have access to some required scopes. For example, a CRM-only portal cannot install an integration that requires the content scope.

If you’re still stuck, I’d recommend creating a separate topic with specific details on the error you’re seeing and the integration you’re trying to install.


#8

Hi @Derek_Gervais, thanks for your answer, luckily i sorted out. but got a new doubt now: Create Hub - not test hub