Inline message not changing on hubspot custom module form


#1

Hello I am trying to have a custom message displayed for my form widget on a custom module. I have tried a few different things like below:

{% form 
        response={message='Custom submission message.'},
        form_to_use=" {{widget.form_field.form_id}}"
 %}

After submit I would expect to see Custom submission message. however what I see is Thanks for submitting the form.


#2

Hi @Ryan_Abs,

Can you try using the response_message tag instead? If that doesn't work, can you send me a link to the page you're working on so that I can take a closer look?


#3
{% form response_message='My response', form_to_use="{{widget.form_field.form_id}}" %}

When I have this to include the form it will still not submit and display "My response"


#4

Hi @Ryan_Abs,

So when you include the following code:

 {% form response_message='My response', form_to_use="{{widget.form_field.form_id}}" %}

The form renders correctly, displays the correct response ('My response'), but doesn't submit? Can you give me a link to the page in HubSpot so that I can take a closer look?


#6

Yeah sure the page is:

The form is at the bottom, when you fill it in, it will submit however the message displayed will be thank you for subscribing despite writing in 'My Response'


#7

Hi @Ryan_Abs,

I hate to be difficult here, but when I navigate to that link I reach a 404 page. I also jumped into your portal, but wasn't able to easily find that page. Can you double check that the page is live and accessible?


#9

Sorry that is my bad. Could you try the page now:


#10

Hi @Ryan_Abs,

Thanks for your patience here; this thread slipped under my radar. I jumped in and did some testing, and it appears that the response_message field only works in tandem with the response_response_type field set to inline. You can see the cloned module I was using to test here: https://app.hubspot.com/beta-design-manager/2605654/modules/6195746471