Insufficient Scopes were Provided


Hi Experts,
I am getting message like “Insufficient Scopes were Provided. Please contact the Integrator” while I am hitting the authorization url like below

I have created an app and I am passing the client id, scope and redirect url.

Let me know if I am missing anything here.

Ecom pipeline issue

@Basha On your app what boxes do you have checked off?



Please find the below.

I have selected all the above mentioned options and passing contacts as scope in the authorization url


@Basha Then you must include all of those scopes in your call. The call you pasted above you only requested the contacts and automation scopes.



Thanks for the reply. Now I am getting message “An Invalid scope name was provided”. I tried passing different combinations. I got either Insufficient scope provided or Invalid Scope provided messages. But not successful yet.



@Basha there is no workflows scope. It is called automation. Check out here for a full list of them.