Invalid scope error with optional scopes


#1

I have required scope of “contacts” and an optional scope of “automation”. In my app settings I have “contacts” and “automation” specified. Do I not need to check “automation” in the app settings as a permission because it is optional? I have some users of mine complaining they are getting an error of “Insufficient scopes were provided. Please contact the integrator”. Any ideas of what could be causing this if not the app settings issue?

Note: Our customer having issues says they have Marketing dashboard enabled on all the accounts they try to connect.


#2

@tryinteract the automation scope is only for workflows and would only work for those who have a Pro or Enterprise portal. The users that it isn’t working for, do they have access to Workflows?


#3

I am not sure, but since I have it as an optional_scope won’t it retry without that scope after it fails? Or will it always force it because of the app settings?


#4

I am not sure, but since I have it as an optional_scope won’t it retry without that scope after it fails? Or will it always force it because of the app settings?


#5

@tryinteract Can you confirm that the users having issues don’t have automation? You only mentioned that they have the dashboard which all users get now.


#6

@pmanca Just got word back from our customer. They recently cancelled the subscriptions on one of their accounts, but the ones they are trying to connect are all Pro accounts and have access to automation.


#7

@tryinteract Do they have the CRM? Some of the older portals don’t have the free CRM turned on by default I think.