Issue: Some HTTP requests that should result in an error response are incorrectly returning HTTP 200 status codes


#1

We've identified an issue where certain requests that should result in an error response are incorrectly returning responses with HTTP 200 status codes and an empty response body. These requests are in fact failing but are returning a successful response, when they should be returning an error. This incorrect response code occurs when the error response body is empty. This issue could affect any of our APIs, but there are two main instances where we've seen this behavior:

  • 404 Not Found errors, primarily when making a GET request for a specific record
  • 415 Unsupported Media Type errors, primarily when making POST or PUT requests to create or update records when the request is missing the appropriate content-type request header.

What's changing?

Beginning on November 13th, these requests will begin returning the correct 4xx error codes. This may mean that you see an increase in 404 or other 4xx errors where HTTP 200 were previously being returned, and your integration may see these HTTP requests as failures where they previously looked like they were succeeding (again, these requests were not actually succeeding). No actual functionality will be changing, outside of the correct HTTP responses being returned.

Please let us know if you have any questions by replying below.


#2

Hi everyone,

This is just a reminder that the fix for this issue is going live tomorrow morning. Please keep in mind that no functionality will be changing with this fix, but you may see an increase in 4xx error responses once this fix is live.

Please let us know if you have any questions by replying below.