it's not showing up under the Ads addon as a new contact being created


#1

We are sending data from a landing page to a HubSpot form, it's sending the contact information fine each time someone fills it out, however, it's not showing up under the Ads addon as a new contact being created. We're wondering is this to do with the HubSpot Cookies tracking? Any help on this issue much appreciated.

Our request is:

Request URL: https://forms.hubspot.com/uploads/form/v2/4606046/eab9a0d7-cdcb-49e8-b37a-1e36f9c6ec2d

firstname=Subbu&email=Subbu%40appinteract.com&business_website=www.appinteract.com&country=USA&hs_context=%7B%22hutk%22%3A%2285f428a2fa1d6412fc22ae549e6651e6%22%2C%22ipAddress%22%3A%22117.98.154.45%22%2C%22pageUrl%22%3A%22http%3A%2F%2Finfo.appinteract.com%2Fgiveawaysweepstakes%22%2C%22pageName%22%3A%22SweepStakes%22%2C%22redirectUrl%22%3A%22https%3A%2F%2Fappinteract.com%2F%22%7D

I see response code as 302 -- 302 when the form submissions is successful and a redirectUrl is included or set in the form settings.


#2

Hi @Subbu_Nama,

A new contact is attributed to one of your ads when a click on that ad led to the web session where the visitor converted via a form for the first time. This needs to be the conversion that creates them as a contact as well. For example, if a contact is created via an offline source in January and then clicks an ad and fills out their first form in March, they are not counted as a new contact in your ads tool because they already existed prior to making their first form submission.

In order to test this, can you give me a link to the particular ad you're referring to? I'd like to take a closer look.


#3

Thanks for your reply.

Kindly find below required information.

Facebook URL: https://www.facebook.com/542168249268164/posts/1043933792424938

Form URL: http://info.appinteract.com/giveawaysweepstakes

Thanks,

Subbu.


#4

Hi @Subbu_Nama,

The request body you posted initially appears correct, but after testing out the form myself I'm not actually seeing the hubspotutk token being included in my form submission. This would explain the issue; can you double check that your form submissions are passing the hutk parameter correctly? Seeing logs for my recent form submissions might also be helpful in diagnosing the issue.


#5

Thanks for your help, we did dig to next level but unfortunately didn't find anything.
Here are the details for more info and kindly suggest us to know what we are missing.

  1. Cookies:


  1. Form Submission:

Your help would be highly appreciated.


#6

Hi @Subbu_Nama,

Thanks for your patience here. That definitely looks correct; are you seeing this specifically when testing? Or are you seeing this 'in the wild'? If you've only seen this during your own testing, it's possible that traffic from your office IP address is being filtered?

If the hutk token is being passed appropriately, then it's possible that this isn't an API related issue at all. It's possible that the contact's you're trying to track shouldn't be appearing at all. A new contact is attributed to one of your ads when a click on that ad led to the web session where the visitor converted via a form for the first time. This needs to be the conversion that creates them as a contact as well. If that's not the case for these contacts, then it's expected that they're not appearing.

If that's not the case, then it's possible there's something going on in-app. If we've eliminated the possibilities above, I'd recommend reaching out directly to our Support team by clicking on the 'Help' widget at the bottom right hand corner of your portal.