JS works in template but not on live page


#1

I created a template in the template editor, using the preview to check that everything was working. once done I created a page with the new template and was receiving errors in my code that were not happening in the preview on the template. The errors were coming from a plugin that I have used many times and have never had any trouble with.

I tried copying the template to another portal and made a page with it, no errors and works just fine. I tried copying a working template from another portal into the portal with the issues and again it worked in preview but not after making a page with it. I thought maybe some script in the header/footer might be messing something up so I removed everything except what was absolutely necessary for it to work and it was still getting errors when made into a page.

the plugin creates the function .slick which you can call like this $(’.class-name’).slick and the error I am getting is “.slick is not a function”. Currently the plugin is pointing to an external site, but I have tried uploading it to hubspot and also placing it in the same script file as the one that makes the call, all of which work in preview mode but not when making a page.

Im not really sure how to proceed on this one, it doesn’t seem to be an issue with the code, but if anyone has any advice it would be helpfull.