"Missing or invalid scope" when passing in contacts as required scope


#1

Getting an error about missing or invalid scopes. Only requesting the ‘contacts’ scope. Any feedback on this?

This was working fine last week and is borked without any changes.

Here’s the url that initiates the oAuth handshake.
https://app.hubspot.com/oauth/authorize?client_id=<client_id>&scope=contacts&redirect_uri=<redirect_uri>

Response
"status":"BAD_SCOPES","message":"missing or invalid scopes","correlationId":"503ab336-e1d2-4324-8ebb-be2f29f224b6","requestId":"ecd667f1a9f434160564ae0397dccad9"


#2

Me, too. I’ve been getting the error since 3 hours before.
Hubspot API changed its spec suddenly?


#3

Our app also experienced exactly the same issue. We had no code or config change on our app and /oauth/v1/token API suddenly started failing consistently with the same error since around 4pm PDT today afternoon. As a result users can’t login and complete oauth and thus can’t use our app. It is still failing 100% of the time now. I can’t find any place to file a ticket and get urgent help. Does hubspot have a support escalation process for integration partners? Thanks!


#4

I am also getting this same issue for most of my clients using this integration (it still works for some of them, for some reason). I’m expecting a storm of complaints from customers relying on this integration for their daily workflow…


#5

I’ve been experiencing the exact same issue. I’m having trouble connecting with some tokens. The response I get is similar to what @Michael_Fellows describes in the post.


#6

I’m getting the same too, even when trying to get the initial access token.

A 403 with this as the body.

{
    "status": "BAD_SCOPES",
    "message": "missing or invalid scopes",
    "correlationId": "e971d068-e03a-4217-8ca3-8bedca374cd2",
    "requestId": "86036be3f24c274b0da2b0d8550fe568"
}

My Hubspot integration is basically broken.


#7

I’m getting the same error while trying to authenticate.

 Array
(
    [status] => BAD_SCOPES
    [message] => missing or invalid scopes
    [correlationId] => ....
    [requestId] => ....
)

#8

We encountered same issue, all of our API calls fails:

{
"status":"BAD_SCOPES",
"message":"missing or invalid scopes",
"correlationId": (...),
"requestId": (...)
}

Do you have found a work around/fix?

Thanks a lot


#9

Does Hubspot provide any way for integration developers to file incidents/tickets for urgent availability issues like this? I can’t seem to find any.


#10

I also am having this issue.

checking all the application scope checkboxes did NOT fix anything

CloudApp
{
  "status":"BAD_SCOPES",
  "message":"missing or invalid scopes",
  "correlationId":"650c0ad2-d705-4023-9232-xxxxxxxxxxxxxxxx",
  "requestId":"809833501a537859f3682xxxxxxxxxxxxxx"
}

#11

Just chiming in to say “me too”. We’ve sent emails and tweeted - hopefully we get an answer and a fix to this issue soon. :slight_smile:


#12

We also get the same BAD_SCOPES response.

{
“status”:“BAD_SCOPES”,
“message”:“missing or invalid scopes”,
“correlationId”:“xxxxxxxxxxxxxxxx”,
“requestId”:“yyyyyyyyy”
}


#13

Hey Everyone,

Just chatted with our development team, this issue should now be resolved. If you go through the Auth flow again, it should work. If that’s not the case, please let us know.

-Zack


#14

Checking all the boxes won’t help you, because the checkboxes must match the URL parameter when you call APIs.


#15

Hi @zwolfson, for the future, is there a faster and more formal way than posting on forum for integration developers to file incidents/tickets to report urgent availability issues like this?


#16

Hi @coffeeocean,

Posting to the forum is the best way to get support for our APIs and development tools, as it’s monitored closely. For particularly urgent issues like this, paid HubSpot customers can also contact Support directly to inform them of the issue.


#17

It’s happening again!


#18

@Derek_Gervais It is down again, can you provide a timeline for a fix?


#19

I confirm I’m also getting this error again:

{‘correlationId’: ‘de6ece8d-7-496d-a276-e18eb6c2b14d’,
‘message’: ‘missing or invalid scopes’,
‘requestId’: ‘6454f4082157a7b0972222c0a2548’,
‘status’: ‘BAD_SCOPES’}


#20

Hi all,

The team recently rolled back changes made to the OAuth system, so this issue should now be resolved. If people experiencing this issue could direct message me with their client ID and refresh token it would help us track down the issue going forward.