OAuth connect for app with event yields The integrator does not have permissions


#1

I’ve added the same scopes, including basic oauth to an app.
When attempting to install on test portal, I get
The integrator does not have permissions to request the set of scopes

It actually worked yesterday, but when I tried to use the token to create an event, I got access denied.

I guessed it was because I didn’t check the scopes on the app, and after doing that, I only get the message above when trying to connect.

Tried on a new test portal too after doing that.

Work in progress?

For reference, here’s the URL I use for auth:

https://app.hubspot.com/oauth/[test-hub-id]/authorize?client_id=[app-client-id]&scopes=contacts+timeline&redirect_uri=about:blank
(tried other redirect uris too)


#2

Hi @Lars-Erik

Did you also test the event creation yesterday? Or today? Access tokens expire after 6 hours, so if you didn’t try to create the event till today, yesterday’s token would be expired, and normally you’d use the refresh token you get when using the code to get the initial access token.

The the permissions error, that may be related to the + in the scopes in the URL. Does that work correctly if you use a space or %20?


#3

Right, I see the whole picture now. Thanks.
We’re adding support for posting timeline events to a .net client we have for the general API.
Wasn’t thinking through the implications of OAuth.
Gonna be a lot of extra work (persistence and refreshing) just to push an event to contacts’ timelines, but I guess it has to be done. Too bad the timeline API doesn’t support regular API keys. It’s a one-off for one of the hubs we manage, so OAuth is really overkill.

The %20 works - might just drop the mention of + in the docs all together?