Permission error when trying to create HubDB table

hubdb
oauth

#1

Our integration creates HubDB tables and it had been working fine until recently, it starts to get errors like:

{"status":"error","message":"This oauth-token (... removed ...) does not have proper permissions! (requires all of [hubdb-admin])","correlationId":"b7e5813f-aee4-4a19-b86d-ce2a49a7b5e2","requestId":"a5e98d69c79bbc472d77d192c5b5bf63"}

I verified that the token has hubdb scope. Is there any change recently that causes this error?


#2

Hi @SAPikachu,

Has there been a change in the permissions of the user that authorized the integration? There was recently a change made to how HubDB permissions are handled on the user level. This change shouldn’t have affected existing user permissions. Can you direct message me with the OAuth token you were using?


#3

This happens with many users including newly authorized users, I just tested with a known user and it was the same error, this user has no recent change. Will send you the token in a moment. Thanks!


#4

@Derek_Gervais let us know if you have any news! We’re trying clear this roadblock so we can move on with building the page in HubSpot :rocket:


#7

@Derek_Gervais I am one of the Inboundlabs customer and this is really critical for us now to get answers on this problem. We have business goals with campaign plannings, we absolutely need to setup landing pages and we are totally blocked on this because of the technical issues mentioned above. Time pass and money not coming because we are stuck.

Thanks for resolving this ASAP!


#8

We recently migrated our scopes, but it looks like your are getting the old scope through oAuth. Pushing a change now.


#9

Hi @davidkubovsky, @toopixel and @SAPikachu,

This issue should now be resolved. Please post here if you encounter this issue again going forward.


#10

Thanks! Just had a check and it is working fine. :slight_smile:


#11

@Derek_Gervais We just encountered another issue on this, another user (portal ID: 4038184) tries to authenticate with hubdb as optional scope, and he has HubDB access, but our app doesn’t get HubDB scope. If we add hubdb to required scope, authentication fails with permission error. Any idea?


#12

Hi @SAPikachu,

Does that user have HubDB admin permissions? Or just read/write/publish permissions? The HubDB admin permission setting is in the Admin tab of the user’s permission page.


#13

Hi Derek,

I am also checking the issue, and the user has the Super admin role. Can you please advise?
“This user is a super admin. Super admins have access to everything in your HubSpot account”


#14

Hey @Derek_Gervais, it looks like the issue is still not resolved, could you fix this?

{“success”:false,“message”:“Error when calling API : [403] missing or invalid scopes”,“data”:{“code”:403,“body”:"{“status”:“BAD_SCOPES”,“message”:“missing or invalid scopes”,“correlationId”:“f3d21523-836c-42dd-9f33-53bb36b77ce4”,“requestId”:“35844e98f089b72038bd2a818c48d669”}",“headers”:{“access-control-allow-credentials”:“false”,“content-type”:“application/json; charset=UTF-8”,“content-length”:“163”,“date”:“Sun, 19 Nov 2017 11:23:07 GMT”,“connection”:“close”},“response”:{“code”:403,“headers”:{“access-control-allow-credentials”:“false”,“content-type”:“application/json; charset=UTF-8”,“content-length”:“163”,“date”:“Sun, 19 Nov 2017 11:23:07 GMT”,“connection”:“close”},“body”:"{“status”:“BAD_SCOPES”,“message”:“missing or invalid scopes”,“correlationId”:“f3d21523-836c-42dd-9f33-53bb36b77ce4”,“requestId”:“35844e98f089b72038bd2a818c48d669”}"},“url”:"",“options”:{}},“sentry”:“9c4b8ed53ce6432c9f293654337f777f”}


#15

Derek, it is pretty urgent now, we keep getting another error for 2 customers at the moment.
But I’m afraid that we will have it in other portals as well.
Can you please help us figure out why we get this error now?

Error when calling API : [403] missing or invalid scopes”,

e.g portalid : 3949648


#16

Hi everyone (@davidkubovsky @SAPikachu @serhat_sama1 @toopixel),

This issue was resolved, and appeared again due to some remaining references to the old hubdb scopes. The scopes have now been updated, and should function correctly going forward. Re-authing the integrations should succeed in installing them. If anyone continues to see this issue going forward, feel free to update this thread.


Missing or invalid scopes while getting OAuth 2.0 Access Token and Refresh Tokens
#17

Hey @Derek_Gervais , We started to get this issue once again.
When trying to install a page;

{“success”:false,“message”:“Error when calling API : [403] missing or invalid scopes”,“data”:

Can you please help us overcome it asap?

cc: @SAPikachu @davidkubovsky


#18

hi everybody, im getting “You do not have the correct role to grant these permissions. Please contact your administrator.” all the time. what permissions is talking about???


#19

just in case, im the one who created the app so there’s nobody else to grant permissions of any kind (unless it is talking about the people from hubspot)


#20

@Serhat_Sama Can you give me more information about when you are seeing this error message? Does the table exist and you are trying to link the table to the page?


#21

@Alejandro_van_Houtte Can you send me which portal you are on and I can take a look.


#22

It is happening when the user clicks on “Install Page” in briX.
This request is being made for HubSpot services.
Please check the JSON response that is given as an Error.