Publish immediately not working in API


#1

Hi

Managed to create pages and edit without issue through the api, however publish_immediately when set to true is never honoured. When I check the response it is clearly set to true. However the page always stays as draft.

I also tried setting is_draft to false, which also made no difference

I can manually publish pages but I really need this done automatically from the api

My scopes are :- contacts content forms automation files timeline

Any idea why this may not be working?

Lee

Example response

“{“ab”:false,“ab_variation”:false,“absolute_url”:“http://4022435.hs-sites.com/-temporary-slug-d1d92fa4-0f62-4f68-9dcb-27bf0ff8bbcd",“allowed_slug_conflict”:false,“analytics_page_id”:“5474653875”,“analytics_page_type”:“landing-page”,“archived”:false,“attached_stylesheets”:[],“author_at”:1513099972441,“blueprint_type_id”:0,“campaign_name”:"Lee Event (29/12/2017 12:00:00)”,“category”:1,“category_id”:1,“created”:1513099972441,“created_time”:1513099972441,“css”:{},“css_text”:”",“current_state”:“DRAFT”,“currently_published”:false,“deleted_at”:0,“domain”:"",“errors”:[],“flex_areas”:{},“freeze_date”:1513099972441,“has_user_changes”:true,“html_title”:“Lee Event (29/12/2017 12:00:00) Webinar Registration Thanks Page”,“id”:5474653875,“is_draft”:true,“is_published”:false,“keywords”:[],“label”:“Lee Event (29/12/2017 12:00:00) Webinar Registration Thanks Page”,“live_domain”:“4022435.hs-sites.com”,“meta”:{“html_title”:“Lee Event (29/12/2017 12:00:00) Webinar Registration Thanks Page”,“campaign_name”:“Lee Event (29/12/2017 12:00:00)”,“publish_immediately”:true,“has_user_changes”:true,“last_edit_session_id”:null,“last_edit_update_id”:null},“name”:“Lee Event (29/12/2017 12:00:00) Webinar Registration Thanks Page”,“page_redirected”:false,“page_title”:“Lee Event (29/12/2017 12:00:00) Webinar Registration Thanks Page”,“personas”:[],“placement_guids”:[],“portal_id”:4022435,“preview_key”:“RgISeyXK”,“processing_status”:"",“publish_date”:0,“publish_date_local_time”:0,“publish_immediately”:true,“published_url”:"",“resolved_domain”:“4022435.hs-sites.com”,“slug”:"-temporary-slug-d1d92fa4-0f62-4f68-9dcb-27bf0ff8bbcd",“state”:“DRAFT”,“subcategory”:“landing_page”,“template_path”:“generated_layouts/5414755432.html”,“template_path_for_render”:“generated_layouts/5414755432.html”,“title”:“Lee Event (29/12/2017 12:00:00) Webinar Registration Thanks Page”,“translated_content”:{},“tweet_immediately”:false,“unpublished_at”:0,“updated”:1513099972441,“url”:“http://4022435.hs-sites.com/-temporary-slug-d1d92fa4-0f62-4f68-9dcb-27bf0ff8bbcd",“widget_containers”:{},“widgetcontainers”:{},“widgets”:{“module_144646050862912567”:{“body”:{“value”:"Lee Event”}},“module_14654875429717740”:{“body”:{“value”:“29 December 2017”}},“module_14721222869725947”:{“body”:{“html”:“


#2

Hi @Lee_Jackson,

The publish_immediately parameter should be set to true if you want to be published immediately when the schedule publish endpoint is called. It doesn’t publish the page immediately on it’s own. You must hit the publish endpoint: