Removing Live Chat from some pages on Single Page Application


#1

Is there any way to remove the chat bubble from certain URLs on a Single Page Application. Adding URL's in targeting does not work because URLs aren't reloaded on Single Page Applications.

This is a serious limitation to Live Chat. In our case it makes it unusable.

Is there any workaround? Even if we could only have it on our home page it would be somewhat usable - but as it is it's either on every page or none. That's not viable - especially when the bubble's position is not movable.


#3

Hi @morgan, adding the ability to change URLs on SPAs for the chat widget is something our team is actually working on as we speak so it should be possible soon, though I don't have a hard date for that. As I know it, however, you should be able to specify which pages it appears on and not have it on every single page. You can get to the settings of a chat widget by going to Settings > Conversations > Inboxes > Hover over your inbox and click edit > Chat > Hover over the targeted message and click edit > Targeting. The URL structure to get there is here: https://app.hubspot.com/live-messages-settings/3430672/inboxes/956/message/6329

Here's what this page looks like:

Have you explored these settings? The knowledge article is here: https://knowledge.hubspot.com/articles/kcs_article/conversations/how-to-use-conversations -- if you command + F for "Targeting" you'll find it.

Edit -- can you also pass along your HubID so we reach out directly when the SPA compatibility for Messages comes out? Thanks!


#4

Hi Connor - thanks for the reply. My id is 5145543 far as I know (that's what shows up in the URL).

I did explore the options you point to - in fact that is the precise problem I was pointing to. Entering URL's in these settings only has an effect if I refresh a page on our SPA. Obviously that isn't practical. So for example, a page I don't want the chat bubble and whose URL I've excluded via these settings will show the bubble when I navigate to it, but if I hit refresh it will disappear.

I assume you are aware of this problem if you say you are working on it.

Please do let me know when there is a fix or if you know any workaround. Hubspot is no use to me until then as I only signed up for this live chat feature.

Thanks,

Morgan


#5

Hey @morgan, thanks for your HubID and the extra info. I thought maybe only a part of your site was an SPA, which is why I pointed out those settings. Yes we are working in fixing the messages widget for SPAs. There are no workarounds at the moment, but you should expect a fix in January or February.