Request for Integration Permissions!


#1

Request for Integration Permissions.

Uh oh!

You do not have the correct role to grant these permissions. Please contact your administrator.

This is what being displayed when I redirect my app to perform OAuth. I have all the previous answers. Nothing helped


#2

Hi @toothless,

Is your user account an admin in the portal you’re trying to authenticate? Can you give the the Hub ID of the portal you’re trying to authenticate?


#3

Yes, The user is an admin. The hub id is 3920927. After the system restart, it worked. I did nothing. No clue how it worked


#4

Hi @toothless,

That sounds strange, but I’m glad to hear everything is working now. Feel free to reach out if you continue to experience issues and we can dig in again.


#5

I’m having the same issue. I’m trying to connect to Domo and I get the same error as above. 3 of us have tried, same results. Our HUB ID is 3894723 any thoughts would be appreciated. @Derek_Gervais Thx!!


#6

Even I’m facing the same issue when trying to connect to Gather Content. Hub Id 458297. I’m not the admin of my account. What are the permissions we required for the integration of Gather content account.?


#7

Hi all,

If you’re experiencing issues installing an integration, I would recommend creating a new topic. This topic is very general, and it’s likely unrelated to your specific issue.


#8

Hi @Derek_Gervais ,
I'm having the same issue, I did a server restart, but still having the error message

"Request for Integration Permissions
Uh oh!
An error occurred while validating the integration authorization."

Please help thank you


#9

My ID is 4641112
Getting Request for Integration Permissions
Uh oh!
This hub doesn't have access to some HubSpot features that are required by this integration.


#10

Hi @Sekar_ThiDiff,

That error means that your integration is requesting access to features that the portal in question does not have access to. For example, you would see this error if your integration is requesting the hubdb scope, but the portal trying to install it did not have access to the HubDB tool. I'd recommend double checking the scopes your integration is requesting, and comparing them with the tools your portal has access to.