Resolved - HUBL Server on Headless Server


#1

Is it possible to run the HUBL server on a Headless Ubuntu Server? We do allow our “local” dev is hosted on cloud servers. No one here has dev environments on their local machine. I was hoping we’d be able to work hubspot dev into our normal workflow and this would be a great help.

Everything looks good, then I get

INFO [2018-01-11 16:23:21,703] com.hubspot.content.bvl: Local HubL Server started, running at http://127.0.0.1:8080/
ERROR [2018-01-11 16:23:21,755] com.yammer.dropwizard.cli.ServerCommand: Unable to start server, shutting down


#2

Hi @dwg-andy,

Thank you for your patience here. That error looks fairly generic; I think it might be thrown whenever there’s any sort of service error. I’ve seen it before when there’s already a service running at a specified port: can you try freeing up port 8080 or running the server on a different port?

If that doesn’t work, can you direct message me with your FTP log for the full errors that you’re seeing? I’ll need to see those in order to adequately troubleshoot this issue.


#3

@Derek_Gervais thanks for the response and sorry for the delay (been a crazy month). I now have the HUBL server running on my box at 127.0.0.1:8080. That’s all good and well. However, now I’m trying to create a virtual host record to point to the running server. ( Obviously, I know this is beyond official support, hence why I’m asking on the community. ) . When I try to reach out to my url :8080 I get chrome telling me it refused to connect.
WebServer: Apache, UWF is inactive

<VirtualHost *:443>
DocumentRoot /home/dubose/dwg_tools
ServerName tools.dubosewebgroup.com
<Directory /home/dubose/dwg_tools>
allow from all
Options None
Require all granted
</Directory>
</VirtualHost>
<VirtualHost *:8080>
DocumentRoot "/home/dubose/dwg_tools/local-hubl-server/bin"
ServerName tools.dubosewebgroup.com
<Directory "/home/dubose/dwg_tools/local-hubl-server/bin">
allow from all
Options None
Require all granted
</Directory>
</VirtualHost>

any ideas?


#4

ok. looks like I may have gotten somewhere. basically followed this example except for port 8080 https://atticuswhite.com/blog/apache-serving-nodejs/
having some issues navigating to the templates, but at least hit the main page for the server.


#5

Another alternative is to bind the host to 0.0.0.0 in your config.yml