Secondly Limit issue


#1

Is it possible that there is a sporadic bug on HubSpot’s side with the secondly limit? Last night there was a period of time that we were getting errors like:

Unable to GET to HubSpot /companies/v2/companies/XXXXXXX (429): message: the server responded with status 429 body: {"status":"error","message":"You have reached your secondly limit.","errorType":"RATE_LIMIT","correlationId":"57b30aa1-cf5b-4172-982c-a3c69d5f4874","groupName":"publicapi:oauth-secondly:XXXX:XXXXX","policyName":"SECONDLY","requestId":"ca08d815a2a9f98a434f71f686313fbe"}

This happened for a period of time a few weeks ago as well. No out of the ordinary processing was happening for us either time and it doesn’t seem likely that we were pushing 10 req/sec.


#2

Hi @homerlex,

I’m not aware of any issues with our rate limiting system, but I’d be happy to take a look. Can you send me the Hub ID of the portal in which you were seeing these errors?


#3

Hi,
we're getting the same error(secondly rate limit) and it's very unlikely that we make 10 request per second. I have also checked the api logging on our hubspot account and I could not find all these requests.
Please help

thanks!


#4

Hi guys,
apology if I write again, is there anything I can look into?

thanks


#5

Hi @pie,

If you don't have some explicit request rate limiting on your end, my guess would be that your service just happened to make 10 requests in a given second at some point. I can take a look to see if there's anything out of the ordinary, though; can you direct message me your Hub ID?


#6

Hi Derek,
I have sent an email with our hubId

thanks a lot


#7

hey,
i faced the same problem :frowning:
Can I reach you out with Hub ID as well?

We checked api logging and seems it's clear