[SOLVED] You do not have the correct role to grant these permissions. Please contact your administrator

oauth
contacts

#1

Hello there,

I’m the author of an HubSpot app which is used to write leads from our app to the HubSpot Contacts (app id: 35904).

The app requests the “contacts” scope, and the “Basic OAuth functionnality” and “Contacts” scopes are checked in the app details.

Until now, it worked perfectly and it’s still working fine for the existing integrations. But if we try to create a new integration (from a fresh portal), then we get the following:

(here is the URL: https://app.hubspot.com/oauth/[HUB_ID]/authorize?client_id=[CLIENT_ID]&redirect_uri=[REDIRECT_URI]&response_type=code&scope=contacts&state=[STATE])

I’m super admin on the portal.

Do you have an idea of what’s going wrong?

Best,


#2

Okay so actually the changes on the HubSpot app require some time to propagate. We retried this monrning and everything went fine.

The solution was to check “Basic OAuth functionnality” and “Contacts” scopes in the app details, and wait for a couple of hours.