Submission rates issue


#1

Hi there!

I have a problem with my form views and submission rates. The form has 39 submissions but shows 0 views and 0% submission rate for some reason. It is connected to the website using API and form ID. Here's the link to the live form just in case - https://www.thinklogical.com/compose-pdf/

Support told me that: "This is expected behavior when we are collecting forms via the API, as we are unable to track the form the same way we would with a standard HubSpot Form. If you keep your form as you have it now ( with a custom built form submitting information to HubSpot via the API ) we will be unable to track that information. If you were to remove the form as you have it now and replace that with the embed code directly from the HubSpot form, we would be able to start tracking that information going forward."

Unfortunately, the solution with embed code doesn't work for us as we will loose some website functionality and logic if we change the form to use an embed code.

So, guys, maybe someone has some kind of the list of tracking parameters (and their names) that should be passed to Hubspot's server and we will be able to correct the code/scripts from our side?


Views and submission rate issues with API
#3

Hi @vadim.plakhtyr,

Support's answer is correct. Unfortunately, I don't have any tracking parameters or endpoints to share with you; all public information on the Forms API is located in our documentation.

As mentioned in this similar topic, form views are tracked when the form embed code is fired, so it's not possible to separate the two.


#4