This hapikey xxx does not have proper permissions! (requires any of [transactional-email, transactional-email-api])


#1

I am trying to send a single email using the api based on this doc -> https://developers.hubspot.com/docs/methods/email/transactional_email/single-send-overview

But, I faced an issue when I tried it.

This is a POST request to "https://api.hubapi.com/email/public/v1/singleEmail/send?hapikey=xxx"
xxx = the valid api key

The entire response I get is:

{
    "status": "error",
    "message": "This hapikey (xxx) does not have proper permissions! (requires any of [transactional-email, transactional-email-api])",
    "correlationId": "89147cb2-3521-44f7-a603-e38077dc2c7a",
    "requestId": "8c0cea296218bd7a4b46285923f4fec7"
}

#3

Welcome, @kiongkiong!

Does your account have the transactional email add-on?

As the documentation notes:

Need%20transactional%20email

If you have the transactional email add-on, please share your Hub ID.


#4

Hey Isaac,

How do I check if my account has that add on?

Going to that link isn't helpful at all


#5

Hey, @kiongkiong.

If you click on your account menu > Products & Add-ons > Add-ons (tab), you should see a list of the add-ons your account has access to. If there is no green check mark on the Transactional Email item, then you don't have the add-on and won't be able to use that API:


#6

Hey Isaac,

Sorry for the super lat reply.

By the way, I have clicked everywhere I can see and I still couldn't find the above. I especially couldn't find the "account menu" section.

Thanks for your help!

Cheers,

Kiong


#7

Hey, @kiongkiong.

The "account menu" is signified by your avatar image and your organization name in the upper right corner of your navigation. See below.

Account%20menu

If you share your Hub ID, I can verify whether or not you have access to the transactional email add-on.


#8

Hey Isaac,

Thanks for showing me clearly where is the account menu.

I can verify that I do not have the Products & Add-ons menu item.

My Hub ID: 5050682

Can you please have a look for me?

Cheers,

Kiong


#9

Thanks for sharing your Hub ID, @kiongkiong.

Your account has a Marketing Hub Starter subscription, which does not support the transactional email add-on, among other add-ons. I guess that is why no Products & Add-ons menu item appears. Apologies for the confusion.

Thus, it is not possible to access the transactional email API with your current subscription level. To use these tools, you would need both of the following:


#10

Hey Isaac,

Thanks for the super prompt reply!

I guess this issue can be closed.

Cheers,

Kiong