This hapikey (xxxxxxx) does not have proper permissions! (requires any of [email-access])


#1

Our account has "Marketing Starter" enabled but we are currently unable to access the Emails API, which according to our account rep, we should have access to. Here is the full json we are getting back:

{
    "status": "error",
    "message": "This hapikey (xxxxxxx) does not have proper permissions! (requires any of [email-access])",
    "correlationId": "4c4a9bb3-6afa-4c19-8492-4508013b7da3",
    "requestId": "cc90f8e82e67a47b058c6e43595d2c39"
}

Any help would be appreciated.


#2

Hi @anthonycats, which endpoint are you using? Can you also provide the HubID that you're attempting this action on? Thanks!


#4

The endpoint is https://api.hubapi.com/email/public/v1/subscriptions.

I'm not sure what you mean by HubID in this situation, but our portal ID is 2035667.


#5

Thanks for the info @anthonycats. To clarify, Portal ID == HubID. In this case, can you also reply with an example body of your PUT request you're making and the full request URL you're using (without hapikey included).


#6

This is a GET request so there is no body, and that is the full url (minus the hapikey)

GET https://api.hubapi.com/email/public/v1/subscriptions?hapikey=xxxxx

Note: this happens on any of the Email endpoints.


#7

whoops! For some reason I thought you'd said you were using PUT. Monday brain I guess.

@anthonycats was able to GET your subscriptions using an internal REST client. Would you mind if I attempt using your hapikey? I can grab it from your Integrations Settings, but just want to make sure its okay with you.


#8

Yep, that should be fine.


#9

Thanks @anthonycats, was able to reproduce this with your hapikey, so I'm reaching out now. Will post here with updates when I have them


This hapikey does not have proper permissions! (requires any of [email-access]) - "Marketing Hub Starter" subscription
#11

Hi @anthonycats, reached out to the email team, who said this is indeed a bug related to Marketing Starter permissions. Engineering is working on a fix - I don't have a hard deadline, but it should be fixed within a week or so.


#13

Hello.
I have similar problem here
When I try to use API for Update email subscription status for an email address (https://developers.hubspot.com/docs/methods/email/update_status)
I get the same error
{"status":"error","message":"This hapikey (xxxxxx) does not have proper permissions! (requires any of [email-access])","correlationId":"cb903cd3-ff53-454b-99b9-08c7b67240e4","requestId":"a9e561d32ca1b6444a9e52c7b4043d0d"}
I use https://api.hubapi.com/email/public/v1/subscriptions/'.$email.'?portalId=4874026' endpoint
This is my problem too, yes? And now I need just wait for your solution, right?
Thank you.


#14

Hi @Serhii_Pylypenko, looks like your portal is also on Marketing Starter and is affected by this bug. Our development team is working on updating the scopes for the Marketing Starter subscription. I'll post here when there's an update :slight_smile:


#15

Hi all, thanks for your patience here. The issue at hand is a bit more labor intensive than we'd originally thought. We are still working on the issue. I don't expect this will be done by the end of the week. I'll provide another update when I have one. Thanks guys!


#16

Hi,

I understand that this issue turned out to be harder to fix that anticipated, but could we get some sort of update on the progress? It's been nearly 2 months and we are still without our paid API functionality.


#17

Hi @anthonycats, checking in with the team on what their plans are