This hub doesn’t have access to some HubSpot features that are required by this integration


#1

Hello there,

We built an integration "Memsource Connector" and it works fine with our test account. However, when a client of ours tries to authorize with OAuth and their HubSpot account, they always get this message:

This hub doesn’t have access to some HubSpot features that are required by this integration. Please contact the integrator.

We use these scopes:


So I suppose that our client's account does not support one or more of them. It would be really helpful if the error message lists unsupported features instead of "some HubSpot features" message because I have no idea what could be wrong there. Is there something we should look into?

Thanks,
Filip


OAuth integration problem (You do not have the correct role to grant these permissions)
#2

Hi @Filip_Rachunek,

It's likely either content or forms, since all portal have the ability to approve contacts and files. This error seems tricky, but in theory the only people that run into this error should not be able to install your integration anyway, since their portal is missing access to features that your integration requires.

If you can give me the Hub ID of the portal in question, I can dig into what features they're missing.


#3

Hi @Derek_Gervais,

Thanks for your response. The ID is 527622.

Filip


#4

Hi @Filip_Rachunek,

Thanks for sending that along. I jumped into that portal and took a look, but it doesn't appear that it should have any issue approving the scopes that are selected in the screenshot you've included above. Is it possible you're including additional scopes in your authorization URL? Could you send me your authorization URL (minus the client ID) as well as a link to your developer portal so that I can take a closer look?

Also, one last question; this shouldn't be the issue, but is the user installing the integration a super admin?