Timeline API Events not appearing on Contact


#1

Hi!

I’m having an issue where Timeline events aren’t appearing on the Contact record.

This topic seems to discuss a very similar issue. The solution the user found (which sounds odd) hasn’t helped in my case.

My App ID is 37134. The Event Type ID is 15591. I’ve set up Oauth 2 for Hub ID 2139209.

I have checked that the Events are not being filtered out. My App appears in the list under Integrations and is checked.

As far as I know, I’m using the new contacts view. At a minimum, I don’t see a link offering to switch me to a new view, as was mentioned in the post I linked above.

I can’t make heads or tails of what’s going on here. The digging I’ve done suggests that the events are partially working. Am I missing something?

  • I receive a 204 response when submitting timeline events.
  • If I submit an event for a contact that does not exist, the contact is created, but the timeline event doesn’t appear.
  • If I submit an event with an event type custom property linked to a contact property, the contact property is updated but the timeline event doesn’t appear.
  • The Monitoring tab in my Developer portal doesn’t display any API calls.

Here’s a link to the Contact I’ve submitted some timeline events to. https://app.hubspot.com/contacts/2139209/contact-beta/1242051/.

And a few timeline event IDs 583d1ef2ec67d, 583d210d235f6, 583d2457e4828, 583d24fe2ceeb, 583d283e0e92f, 583d2aded9b28.

Any help or suggestions would be super appreciated!


Timeline API event doesn't appear on UI
#2

Hi @jacklyn_m

I think this is an issue with how you’re setting the timestamp for the events. Looking at that contact record, I do see 4 timeline events, but they’re appearing in the timeline in 1970, so you’ll need to scroll for a while to see them. The timestamp needs to be set using milliseconds, so if you’re currently working with seconds you’d just need to multiply the values by 1000.


#3

Ah, thanks! That’s my mistake!

I swear the 1970 dated events weren’t appearing last night, but I do see them now. It’s possible I just needed sleep!