Timeline events created via API are not visible in Hubspot frontend

timeline

#1

Hi,
I created an app and defined a custom timeline-event. Than I created some events for an existing contact and they appeared on the activity timeline of the contact as expected. A few days later these events where no longer visible at the same contact.
I tried to update the events via the API. I got no error but still not visible. I tried to create a new event for a new not existing email -> A contact has been automatically created, but the event is not visible in the activity timeline of this contact (in the activity filter all events are enabled). The timestamp I used is in milliseconds and even if I do not specify any timestamp it makes no difference.

The link to the last contact is:
https://app.hubspot.com/contacts/4787124/contact/41951/?interaction=note

Why are the events not visible in the activity timeline?


Engagements created through API not showing up in Deal timeline
#3

Hi, @tobias_encore_io.

We've received a report from at least one other customer of this behavior and the team is investigating. Apologies for the inconvenience.

I'm able to make the timeline events appear by unchecking and rechecking the timeline filter for "Encore" app events, per this screencast. Can you confirm you see the same?


#5

Hi

This is happening for us as as well.

After checking and unchecking the filters there is a 50% chance (I'm just guessing my probabilities here) that my events show up.

Seems to be intermittently showing and not showing.


#6

Thanks for the response.

I tried that but in none of 10 tries it worked for me. Only if I use the "select all" option it works sometimes. But even if the chance is 50% or 90%, it is no way to go. It is a really critical thing because business decisions will be made on base of this event information and if there aren't any events, nobody tries to switch the filter on and off multiple times to check if this is really right.

Would be great if the topic could get a high priority.

Thanks in advance


#7

We have the same problem since yesterday. In the end we also discovered a workaroud how to temporarily fix it by unchecking and rechecking "Select all" checkbox. Unfortunately this only works until you sign out from Hubspot :frowning:


#8

Thank you all for the feedback. Apologies again for the inconvenience.

I've notified the relevant product team of the urgency of this issue and will update here as soon as I have more detail!


#9

@miogalang and @neumann, could you respond with your Hub IDs? It will help our team track this issue.


#10

@Isaac_Takushi HubID 3999209


#11

Hi @tobias_encore_io, @miogalang, and @neumann.

The team just pushed a fix and Timeline API events should now appear by default. I checked the example contact in account 4787124 and it loaded for me.

Can you all confirm whether the issue is resolved for you?


#12

I confirm that it works correctly. Thanks for the quick bugfix :wink:


#13

Works for me too.
Great work.
Thank you.


#14

Thanks works for me too