Unable to receive Access Tokens via Connecting to Hubspot - SSIS CozyRoc Connector


#1

Hi there

We're currently trying to connect to Hubspot via SSIS CozyRoc connector.

My colleague had previously connected via the CozyRoc Rest Source Editor, (how to guide as per https://www.hubspot.com/integrations/cozyroc)

  • Selected Hubspot Connection Manager
  • Click new Token File
  • then added in the Portal ID

The issue is when a window pops up with the following

"Let's get fresh.
It looks like you're using Internet Explorer 9.0, which is no longer supported by HubSpot. Please install a freshly updated version of your browser. It's easy, and free."

  • Have then copied the url link at the top of tha page and pasted into Chrome and get a 404 error page redirect to CozyRoc, saying the page no longer exists.

I have updated the browser settings in Visual Studio and Internet Explorer to default to chrome but still appear to get the same issue.

Has anyone else experienced this issue and the best way to fix

Thanks

Max


#2

Hi!
I'm having the same issue. Did you ever find out how to resolve this?
Thanks!
Tracy


#4

Hi @Max_Taylor and @tbackus,

Beyond ensuring that Google Chrome is Window's default browser, this forum probably won't be your best resource for specific implementation issues like this.

COZYROC built and maintains this integration with HubSpot and they specified this form for support inquiries. Have you reached out there?


#5

Yes, I am in contact with them also.


#6

I just worked with them and finally got it to work... Basically you need to open visual studio, then change the following value in the registry
devenv.exe set to 11000 (decimal)
located:
HKCU\Software\Microsoft\Internet Explorer\Main\FeatureControl\FEATURE_BROWSER_EMULATION & HKLM\Software\Microsoft\Internet Explorer\Main\FeatureControl\FEATURE_BROWSER_EMULATION

Then it works

Anyone have any suggestions for the message I am getting now:

Uh oh!

Insufficient scopes were provided. Please contact the integrator.
I am using a super admin account (not ideal I know)


#7

Welcome, @marcsloope!

Are you receiving that error when attempting to connect COZYROC?

Per Derek's post here, that error actually refers to the scopes available in the account rather than the user's permissions. It may be that COZYROC is asking for scopes to a tool you don't have in your account (e.g. HubDB isn't available to all subscriptions).

To troubleshoot effectively, I'll need to know your Hub ID and the scopes COZYROC is asking for. If you can send me the authorization URL COZYROC is using (e.g. https://app.hubspot.com/oauth/authorize/?client_id=client_id&redirect_uri=https%3A%2F%2F%2Foauth_redirect.html%3Fstate%3D23575&scope=contacts%20forms%20content), I should have enough information to identify the issue.