Unable to retrieve contacts for a company


#1

I created a couple contacts within the Hubspot UI. Their email addresses then generated a company and associated them to that company. When I attempted this call:

GET /companies/v2/companies/:companyId/contacts

It returned an empty array. I then attempted to manually associate the company and contact via an update on the contact’s “associatedcompanyid” property. This still didn’t link them together when making the GET company contacts call.


#2

I’m trying to do the same thing!


#3

Hi @clintonskakun and @connorsan

Can you send me a link to a company where you’re seeing a difference between what the app shows and what the API shows?


#4

I believe it’s a syncing issue of some sort. The company was automatically generated when the domain for the email address was entered. For some reason, the GET /companies/v2/companies/:companyId/contacts call didn’t work the day of creation. The next day I tested that endpoint again, and it worked.


#5

I just never found the docs for the endpoint so I didn’t know where to send the request.

EDIT: Whoops, I guess it was this(GET /companies/v2/companies/:companyId/contacts
). Sorry about that


#6

@dadams
I've had my contact associated via email automatically for many days and I'm still not seeing the contacts when making the call GET /companies/v2/companies/:companyId/contacts

Example of one that does NOT work because it was automatically synced: https://app.hubspot.com/contacts/4239642/company/673450579/?interaction=note

Company that DOES work because it was manually associated: https://app.hubspot.com/sales/4239642/company/673556369/?interaction=note


#7

Hi @Carlos_Mostek,

I'm able to pull the associated contacts for that first company using the endpoint you specified. Can you give me some more information on the response you're getting?